November, 2025
Incident Updates
RESOLVED
Second SteamTools server outage
Updates
- RESOLVED
The SteamTools server is now fully back online! 🥳
If your games still say
PURCHASEinstead ofPLAY, restart Steam through SteamTools. - MONITORING
The server came back up ~30 minutes ago (as of the time this update is posted) and is still up. If the server doesn't go back down again in the following 2-3 hours this incident will be marked as resolved.
- IDENTIFIED
No updates yet, just wanted to clarify that during the outage, all games added with SteamTools will show up as
PURCHASEinstead ofPLAY. You can try fixing that by restarting Steam until they appear asPLAYagain - IDENTIFIED
It's been confirmed by the people behind SteamTools that the server is currently down due to a DDOS attack. The availability seems to fluctuate, so if you keep restarting Steam you may get it to work.

- INVESTIGATING
The SteamTools server is really unstable today as seen in the screenshot below:
The red/orange parts are when it's detected as being downThere's no official statement from the people behind SteamTools about this yet.
Aditionally after yesterday's server outage, SteamTools is now having trouble bypassing SteamStub for many games. So, if you’re getting an error like in the screenshot below, use Steamless.

RESOLVED
Third SteamTools outage
Updates
- RESOLVED
The SteamTools server is fully back online! 🥳
Manifest retrieval has been fixed and it doesn't seem like there are any other issues at the moment. If any issues do appear, this incident will be updated. They hopefully now have proper DDOS protection and this won't happen again :)
- INVESTIGATING
Manifest retrieval is currently broken. This means your downloads/updates will fail with the
UNKNOWN ERRORorNO INTERNET CONNECTIONerrors. - MONITORING
SteamTools has switched to a different hosting provider and the server seems to be fully back now. If the server stays stable for 3+ hours this incident will be marked as resolved.
If you're still having issues, try restarting your PC and trying again. If the issue you're having persist, try waiting until it's confirmed that the server is fully back and stable.
- IDENTIFIED
Recently, I've noticed this image (see below) being passed around on the SteamTools Telegram group. I've also gotten a DM on Discord asking if that's legit, so I assume this image has been spread around quite a lot by now.
This is not real and was not written by us. The person that made this image just used inspect element to edit this page (for themselves, not everyone). You people shouldn't trust everything you see on the internet. Always do your own research.
The fake imageIf you have the original source of the image shown above, please contact me.
As for the SteamTools server, no updates. It's still completely down and there are no news from the people behind SteamTools.
- IDENTIFIED
Since SteamTools uses GeoDNS (which basically allows them having multiple servers around the world), some regions could be not experiencing this outage at all.
- IDENTIFIED
Since the last update posted here it's gotten way worse. The server has been down for 2+ hours at the time of posting.
- RESOLVED
Seems to be mostly fine now, shouldn't even consider todays "outage" as an outage.
- MONITORING
The SteamTools server has been running without availability disruptions for 2 hours (at the time of posting). If there will be no further availability disruptions in the following 1-2 hours, this incident will be marked as resolved.
- IDENTIFIED
The server became unstable again at around 3:10 AM (UTC+2), it's not nearly as bad as yesterday though.
The red/orange parts are when it's detected as being downIt's been confirmed that this is a DDOS from the people behind SteamTools.
RESOLVED
Unknown server outage
Updates
- RESOLVED
This incident has been resolved.
- MONITORING
This was happening because the Intel graphics driver was constantly polling to check if there are any displays connected (I'm running my server headless), using up the whole CPU. This should now be (hopefully) resolved.
The website will now experience a bit of downtime because I need to restart the whole server to apply the fix.
- MONITORING
A full restart of the server seems to have fixed it. I can see it has went down for a few minutes over the past couple of days, so i'll investigate this further.
- INVESTIGATING
My server seems to have died completely, because I am unable to even remote connect to it.
RESOLVED
SteamUI Search outage
Updates
- RESOLVED
SteamUI is back online, you should now be able to download from the website.
- INVESTIGATING
SteamUI, a service we rely on, is experiencing a complete outage. During this outage you'll be unable to download from the website.
RESOLVED
Cloudflare outage
Updates
- RESOLVED
Cloudflare appears to be fully operational now. The website is now back online.
- MONITORING
Cloudflare seems to be recovering now. The website will remain offline until it's confirmed Cloudflare is completely operational.
- MONITORING
Cloudflare is currently experiencing a complete outage. The whole internet is basically down (yes, including SteamTools). The only unaffected service is the Usage Guide.
More info: https://www.cloudflarestatus.com/
RESOLVED
File downloading is broken
Updates
- RESOLVED
A fix has been implemented and the website is back online.
- IDENTIFIED
SteamUI, a third-party service we rely on to get game data in the backend has implemented some aggressive ratelimiting. Due to this, the backend is being ratelimited, which causes the "Invalid AppID" and "Captcha verification failed" errors.
- INVESTIGATING
Most users are unable to download the .lua files for games on the website.
RESOLVED
SteamTools outage
Updates
- RESOLVED
Works for me now, and the few other people in the Manifestor.cc Discord server. The response times are also back to normal.
- INVESTIGATING
It looks like SteamTools is currently experiencing an outage. This hasn't been confirmed yet, but I'm experiencing it myself as well as a few other people in the Manifestor.cc Discord server.